Starter Problems of Nissan Armada



Nissan Armada owners have reported 2 problems related to starter (under the electrical system category).

car image   Starter problem of the 2006 Nissan Armada 1
Failure Date: 01/13/2007

The contact owns the 2006 Nissan Armada. While driving on a rainy night at 55 mph she heard a loud noise. She stopped the vehicle and noticed that the bolts broke off from the tie rod that was connected to the axle. The failure mileage was 18,000. The vehicle was towed to the dealer. The contact stated that the manufacturer replaced the axel. Since purchasin, the vehicle there were several failures that occurred, the safety sensor and the heat was not operating properly. There was recal campaign # pb014, according to the manufacturer. The manufacturer tried to contact all the owners of this vehicle. The contact filed a complaint with state attorney general. The current mileage was 21,000. Updated 03/30/07.

See all problems of the 2006 Nissan Armada.

car image   Starter problem of the 2004 Nissan Armada 2
Failure Date: 07/27/2005

In November 2004 I purchased the Armada 2004. I drove it to florida in December 2004 and left it in my house. I left with the military until June 2005, I drove the vehicle several times until July 2005, in which, one morning I try to turn it on, the vehicle did not start and it sounded like the battery or starter was not working properly. The battery gage went from half way to the negative side and then back to the middle and once again to the negative side again. The control systems are still showing negative information of being off or on. I have not taken it in for a check up due to I purchase the vehicle in NY and I am in FL. I have to check with the NY dealer if I could take it any Nissan dealerships in FL. I will report back on any information from the local dealership. If any one has had similar problem post it thank you.

See all problems of the 2004 Nissan Armada.


Other Common Electrical System related problems of Nissan Armada